Search performance degradation

Incident Report for Goodstack

Resolved

Between 07:26 and 08:19 UTC, organisation search experienced degraded performance, with some requests returning errors or timing out. The majority of requests continued to succeed throughout, and no other services were affected. The cause was an unusual spike in automated traffic, which we identified and restricted. Search has been fully operational since 08:20 UTC. There was no data loss or security impact. We are putting additional safeguards in place to prevent a recurrence.
Posted Jul 23, 2026 - 08:35 UTC

Update

We have identified the cause as an unusual spike in automated traffic to our organisation search endpoint, which placed it under heavy load. We have identified the source and restricted it, and error rates are returning to normal. We are monitoring to confirm full recovery.
Posted Jul 23, 2026 - 08:19 UTC

Investigating

We are investigating elevated error rates and slow responses on organisation search. Other parts of the platform are unaffected. Some search requests may fail or time out and can be retried. We will post another update shortly.
Posted Jul 23, 2026 - 07:45 UTC
This incident affected: Search.